Is there a minimum requirement to access the National Geographic App?

Yes, in order to continually keep in line with Apple mandates, the minimum iOS requirement for the National Geographic app is iOS10 or higher.

For the Android operating system, the minimum requirement is 4.4 or higher.
Still need help?